Cara Konfigurasi DHCP pada Cisco Switch

Sedikit share soal konfigurasi Cisco switch apabila ingin digunakan sebagai DHCP server, hal yang dibutuhkan adalah :

  • Data-data network yang akan digunakan
  • Daftar IP Address yang akan diexclude

Berikut gambaran topologinya

dari gambar diatas terlihat terdapat 3 vlan dengan network yang berbeda, dalam posisi tersebut tidak terdapat sama sekali DHCP server yang dedicated di create sehingga harus setting ip static secara manual ke user-user yang terdaftar, sungguh pekerjaan yang melelahkan, kalau usernya sedikit sih ngk masalah, namun bayangkan apabila usernya mencapai ratusan, ….?

OK kita mulai saja tutorialnya, asumsi saya semua sudah memahami soal setting vlan untuk masing-masing device cisco yang ada. kalaupun tidak akan saya coba review sedikit .

##Core Switch

Core Switch merupakan perangkat switch Layer 3 yang memiliki kemampuan untuk routing dan vlan management
Setting vlan di core switch :
core(config)#vlan 2
core(config-vlan)#name Network2
core(config)#vlan 3
core(config-vlan)#name Network3
core(config)#vlan 4
core(config-vlan)#name Network4

core(config)#interface vlan 2
core(config-if)#ip address 10.10.10.1 255.255.255.0
core(config-if)#no shut

core(config)#interface vlan 3
core(config-if)#ip address 10.10.11.1 255.255.255.0
core(config-if)#no shut

core(config)#interface vlan 4
core(config-if)#ip address 10.10.12.1 255.255.255.0
core(config-if)#no shut

settingan diatas digunakan untuk alokasi vlan di core dan assign ip address untuk gateway dari masing masing network, karena dalam hal ini core switch bisa juga berfungsi sebagai router.

Setelah itu arahkan ip helper address ke ip tempat dhcp server berada dalam hal ini ip address dari core switch adalah 10.10.9.1/24 karena interface vlan1 merupakan interface management dari perangkat cisco by default.

core(config)#interface vlan 2
core(config-f)#ip helper-address 10.10.9.1
core(config)#interface vlan 3
core(config-f)#ip helper-address 10.10.9.1
core(config)#interface vlan 4
core(config-f)#ip helper-address 10.10.9.1

Misal yang ingin kita exlude adalah IP
10.10.10.1 – 10.10.10.30
10.10.11.1 – 10.10.11.30
10.10.12.1 – 10.10.12.30

maka confignya
core(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.30
core(config)#ip dhcp excluded-address 10.10.11.1 10.10.11.30
core(config)#ip dhcp excluded-address 10.10.12.1 10.10.12.30

lalu kita bikin Dhcp Poolnya :

core(config)#ip dhcp pool vlan2
core(config)#network 10.10.10.0 255.255.255.0
core(config)#default-router 10.10.10.1
core(config)#dns-server 10.50.1.5
core(config)#domain-name iseng.com

core(config)#ip dhcp pool vlan3
core(config)#network 10.10.11.0 255.255.255.0
core(config)#default-router 10.10.11.1
core(config)#dns-server 10.50.1.5
core(config)#domain-name iseng.com

core(config)#ip dhcp pool vlan4
core(config)#network 10.10.12.0 255.255.255.0
core(config)#default-router 10.10.12.1
core(config)#dns-server 10.50.1.5
core(config)#domain-name iseng.com

For hasilnya
ip dhcp excluded-address 10.10.10.1 10.10.10.30
ip dhcp excluded-address 10.10.11.1 10.10.11.30
ip dhcp excluded-address 10.10.12.1 10.10.12.30

ip dhcp pool vlan2
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 10.50.1.5
domain-name iseng.com

ip dhcp pool vlan3
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
dns-server 10.50.1.5
domain-name iseng.com

ip dhcp pool vlan4
network 10.10.12.0 255.255.255.0
default-router 10.10.12.1
dns-server 10.50.1.5
domain-name iseng.com

Silahkan untuk dicoba, untuk tutorial lengkapnya dapat diakses melalui web sbb :

http://www.cisco.com/en/US/docs/ios/12_0t/12_0t1/feature/guide/Easyip2.html

Jangan lupa untuk tambahkan perintah “no ip dhcp conflict logging” karena apabila logging diaktifkan akan menyebabkan buffer dari dhcp menjadi penuh, sehingga akibatnya tidak bisa memberikan ip dhcp apabila ada permintaan.

Selanjutnya setelah konfigurasi dhcp selesai seharusnya semua user yang menjadi client dari switch dibawahnya sudah mendapatkan ip berdasarkan alokasi vlan untuk masing-masing port yang terdaftar pada member vlan tertentu

View indrihadi wibowo's profile on LinkedIn

About these ads

2 Comments

  1. sudarma said,

    March 1, 2011 at 7:08 pm

    Cara membuat menset salah satu IP kita genggam (IP Statik)peruntukan server / NMS

    • bayu said,

      March 28, 2011 at 11:08 am

      kalau cara untuk reserve static IP untuk server maupun host adalah sbb :

      ip dhcp pool “name”
      host x.x.x.x 255.255.255.255
      client-identifier “host mac address”
      dns-server x.x.x.x x.x.x.x
      default-router x.x.x.x
      client-name “name”
      domain-name xx.co.id
      netbios-name-server x.x.x.x x.x.x.x “kalau masih pake wins server kalau ngk ada ya ngk usah di configure”


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: