Cisco Password Recovery Procedure

This document describes the procedure for recovering enable password or enable secret passwords. These passwords are used to protect access to privileged EXEC and configuration modes. The enable password password can be recovered, but the enable secret password is encrypted and can only be replaced with a new password using the procedure below.

This password recovery procedure can also be used for the following products:

* Cisco 806
* Cisco 827
* Cisco uBR900
* Cisco 1003
* Cisco 1004
* Cisco 1005
* Cisco 1400
* Cisco 1600
* Cisco 1700
* Cisco 2600
* Cisco 3600
* Cisco 4500
* Cisco 4700
* Cisco AS5×00
* Cisco 6×00
* Cisco 7000 (RSP7000)
* Cisco 7100
* Cisco 7200
* Cisco 7500
* Cisco uBR7100
* Cisco uBR7200
* Cisco uBR10000
* Cisco 12000
* Cisco LS1010
* Catalyst 2948G-L3
* Catalyst 4840G
* Catalyst 4908G-L3
* Catalyst 5500 (RSM)
* Catalyst 8510-CSR
* Catalyst 8510-MSR
* Catalyst 8540-CSR
* Catalyst 8540-MSR
* Cisco MC3810
* Cisco NI-2
* Cisco VG200 Analog Gateway
* Route Processor Module

Step-by-Step Procedure

Follow this procedure to recover the enable password or enable secret passwords.

1. Attach a terminal or PC with terminal emulation to the console port of the router. Use the following terminal settings:

9600 baud rate
No parity
8 data bits
1 stop bit
No flow control

2. If you still have access to the router, type show version and record the setting of the configuration register; it is usually 0×2102 or 0×102. Click here to see the output of a show version command.

3. If you don’t have access to the router (because of a lost login or tacacs password), you can safely consider that your configuration register is set to 0×2102.

4. Using the power switch, turn off the router and then turn it back on.
Important: To simulate step 4 on a Cisco 6400, pull out and then replace the Node Route Processor (NRP) or Node Switch Processor (NSP) card.
To simulate step 4 on a Cisco 6×00 using NI-2, pull out and then replace the NI-2 card.

5. Press Break on the terminal keyboard within 60 seconds of the power-up to put the router into ROMMON.
If the break sequence doesn’t work, see Standard Break Key Sequence Combinations During Password Recovery for other key combinations.

6. Type confreg 0×2142 at the rommon 1> prompt to boot from Flash without loading the startup configuration from the nonvolatile RAM (NVRAM).

7. Type reset at the rommon 2> prompt.
The router reboots but ignores its saved configuration.

8. Type no after each setup question or press Ctrl-C to skip the initial setup procedure.

9. Type enable at the Router> prompt.
This puts you in enable mode where you can see the Router# prompt.

10. Important: Type configure memory or copy startup-config running-config to copy the NVRAM into memory. Do not type configure terminal or copy running-config startup-config or write memory. This erases the router configuration stored in the NVRAM.

11. Type write terminal or show running-config.
The show running-config and write terminal commands show the configuration of the router. In this configuration, you see under all the interfaces the shutdown command, which means all interfaces are currently shutdown. Also, you can see the passwords (enable password, enable secret, vty, console passwords, and so on) either in encrypted or unencrypted format. The unencrypted passwords can be re-used; the encrypted ones have to be replaced with new passwords.

12. Type configure terminal and make the changes.
The prompt is now hostname(config)#.

13. Type enable secret < password > to change the enable secret password, for example.

14. Issue the no shutdown command on every interface that is used. If you issue a show ip interface brief command, once you exit the configuration mode (Ctrl-z), every interface that you want to use should be “up up”.

15. Type config-register 0×2102, or the value you recorded in step 2. This makes the router load the startup configuration from the NVRAM during the next reload.

16. Press Ctrl-z or End to leave the configuration mode.
The prompt is now hostname#.

17. Type write memory or copy running-config startup-config to commit the changes.

Sample Output
The sample output shown here is the result of the password recovery procedure on a Cisco 4700 Series Router. Even if you are not using a 4700 router, this example should be almost exactly what you experience on your device.

Router>enable
Password:
Password:
Password:
% Bad secrets

Router>show version
Cisco Internetwork Operating System Software
IOS ™ 4500 Software (C4500-IS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Jul-02 17:29 by pwade
Image text-base: 0×60008948, data-base: 0×60C74000

ROM: System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

BOOTLDR: 4500 Software (C4500-BOOT-M), Version 11.3(10),
RELEASE SOFTWARE (fc1)

Router uptime is 0 minutes
System returned to ROMby reload at 17:34:58 UTC Tue Aug 1 1995
System image file is “flash:c4500-is-mz.122-10b.bin”
cisco 4700 (R4K) processor (revision B) with 32768K/16384K bytes of memory.
Processor board ID 02169303
R4600 CPU at 133Mhz, Implementation 32, Rev 2.0, 512KB L2 Cache
G.703/E1 software, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
6 Ethernet/IEEE 802.3 interface(s)
8 Serial network interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
4096K bytes of processor board Boot flash (Read/Write)
Configuration register is 0×2102

Router>

!— The router was just powercycled and during bootup a
!—break sequence was sent to the router.

!

monitor: command “cisco2-C4500″ aborted due to user interrupt

>

>confreg 0×2142

You must reset or power cycle for new config to take effect

>reset

System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

Copyright (c) 1995 by cisco Systems, Inc.

C4500 processor with 32768 Kbytes of main memory

Self decompressing the image : ##################################
#######################################################
################################# [OK]

program load complete, entrypt: 0×80008000, size: 0×6a6b30

Self decompressing the image : ################################
#################################### [OK]
Restricted Rights Legend

…….

< …snip>

……

— System Configuration Dialog —

Would you like to enter the initial configuration dialog?[yes/no]:n

Press RETURN to get started!

00:00:05: %LINK-3-UPDOWN: Interface Serial0, changed state to down
…… < ..snip>

00:01:29: %LINK-5-CHANGED: Interface Ethernet5, changed state to
administratively down

Router>

Router>enable
Router#copy startup-config running-config
Destination filename [running-config]?

1012 bytes copied in 0.276 secs (3667 bytes/sec)

Router#show running-config
Building configuration…
Current configuration : 1084 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$uQ7K$rfZtMRsWsFagqsW4/9K0b1

!— Since the password is encrypted, we need to replace
!— the password with the new one.

!
ip subnet-zero
!
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.0.0.0
media-type 10BaseT
!
interface Ethernet1
no ip address
shutdown
media-type 10BaseT
!
Ouput Omitted
!
interface Serial0
ip address 172.16.1.1 255.255.0.0
!
Ouput Omitted
!
ip classless
no ip http server
ip pim bidir-enable
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#enable secret < password > [Choose a strong password with at least one capital letter, one number, and one special character.]

Router(config)#^Z
00:05:23: %SYS-5-CONFIG_I: Configured from console by console
Router#show ip interface brief

…< …output omitted>

Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface ethernet 0
Router(config-if)#no shutdown
Router(config-if)#
00:08:06: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Router(config-if)#^Z
Router#
00:09:21: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router#
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]

Router#show version
Cisco Internetwork Operating System Software
IOS ™ 4500 Software (C4500-IS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Jul-02 17:29 by pwade
Image text-base: 0×60008948, data-base: 0×60C74000

ROM: System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

BOOTLDR: 4500 Software (C4500-BOOT-M), Version 11.3(10), RELEASE SOFTWARE(fc1)
Router uptime is 10 minutes

……< ..snip>

……

8192K bytes of processor board System flash (Read/Write)
4096K bytes of processor board Boot flash (Read/Write)

Configuration register is 0×2142

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#config-register 0×2102
Router(config)#^Z
Router#show version
Cisco Internetwork Operating System Software
IOS ™ 4500 Software (C4500-IS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Jul-02 17:29 by pwade
Image text-base: 0×60008948, data-base: 0×60C74000

ROM: System Bootstrap, Version 5.2(7b) [mkamson 7b], RELEASE SOFTWARE (fc1)

BOOTLDR: 4500 Software (C4500-BOOT-M), Version 11.3(10), RELEASE SOFTWARE (fc1)

Router uptime is 11 minutes

…….< ..snip>

……

00:11:02: %SYS-5-CONFIG_I: Configured from console 4096K bytes of processor board
Boot flash (Read/Write)

Configuration register is 0×2142 (will be 0×2102 at next reload)

Source: cisco.com

1 Comment

  1. March 12, 2016 at 10:34 pm

    Thank you for every other wonderful post.
    Where else may just anyone get that kind of information in such an ideal manner of writing?
    I have a presentation next week, and I’m at the search for such
    information.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: